Registration Form - Step 16 Not Working!

image

This is my code above and it just seems that there’s a glitch or bug somewhere. I have reset multiple times and have even cleared my web browser cache just in case. Still nothing.

1 Like

Hi Caylem. That looks good and it does work for me when I submit it like that. I also tried it with just <input> and that validated too. Did you try this on another browser?

Thanks for the feedback. Unfortunately still does not work.

Geez Caylem, that is bogus. So sorry that it does not work. Your original solution looks correct, and your second attempt worked without issues for me too. If you have tried another browser too, then I really do not know what to advise further. Perhaps reach out to support at support@freecodecamp.org and let them have a look at these screenshots too? Would be a shame if you get stuck on course completion for something this silly.
lesson16

Hi, Caylem!

Is step 16 still giving you issues?

Hi Mohammed,

Still having the problem but I’ve contacted freecodecamp support.

Thanks

Thanks Syl, I have contacted them.

Hi Caylem!
I think you’re missing the closing tag of the input, which should go right after the opening tag in this step. (I’m looking at the second picture you posted.)

My code (that works):

Hi Maila!

Input is a self closing tag and has no closing tag, both his example with <input /> as well as the simple<input> work for us but not for Caylem. Thanks for your input though, but have another look at the HTML documentation.

Hi, Caylem!

Ah, good. That is a good suggestion from Syllie.
It’s so strange, your code looks right, but clearly there is something off! Did you copy and paste any part of your code? Sometimes invisible characters are introduced in the process.

Anyhow, hope the issue is resolved soon. Please keep us posted. Would really like to know what the issue is!

Take care,
Mohammed

Hi Syl!

You’re right, I likely wasn’t thinking when I worked on the issue :joy: And the fact that my code passed did not help me notice my mistake.
@caylemharris2923931 Let us know if you get through with it!

1 Like

Did you make sure there are no characters before and after ?

Caylem,

Try adding “/” inside your input elements. -input /-

Managed to sort my issue out. It seems as if some of my current extensions in Google Chrome were clashing with some functionality on the freeCodeCamp website. So all I done was sign out of my Google account and continue as guest without any extensions or fluff activated and voila, I managed to finish the Registration Form section.

Thanks for all the support and help guys. Got a great community here :+1:t3::ok_hand:t3:

4 Likes